Form Processing Issues Observed
Postmortem

On June 20th, 2022, Helix Form processing was delayed for about 4 hours. During this timeframe, new form submissions were still accepted, but would not show up in the target spreadsheets. After the issue has been resolved, normal processing resumed and all stalled form submissions were delivered.

The issue was caused by a manual rotation of a security credential.

Posted Jun 20, 2022 - 05:34 UTC

Resolved
This incident has been resolved.
Posted Jun 20, 2022 - 04:45 UTC
Investigating
We are observing issues that are affecting form processing for Project Helix customers. The issue is under active investigation and we are working with full effort to reach a speedy resolution.
Posted Jun 20, 2022 - 00:45 UTC